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1. Introduction

The Altera® Quartus® Prime design software is a multiplatform design environment that
easily adapts to your specific needs in all phases of FPGA and CPLD design. Quartus Prime
software delivers the highest productivity and performance for Altera FPGAs, CPLDs, and
HardCopy® ASICs. Quartus Prime software delivers superior synthesis and placement and
routing, resulting in compilation time advantages. Compilation time reduction features
include:

* Multiprocessor support

* Rapid Recompile

* Incremental compilation

Incremental Compilation and Rapid Recompile Quartus Prime Analysis and Synthesis,
together with the Quartus Prime Fitter, incrementally compiles only the parts of your design
that change between compilations. By compiling only changed partitions, incremental
compilation reduces compilation time by up to 70 percent. For small engineering change
orders (ECOs), the Rapid Recompile feature maximizes your productivity by reducing your
compilation time by 65 percent on average, and improves design timing preservation.

2.Installing Quartus Prime 16.1 Lite

2.1 Download Quartus Prime 16.1 Lite

This section provides detailed instructions for downloading and installing Intel FPGA
software.
You download software from the Download Center on www.altera.com. You have several
options for downloading software:

* Download a bundled set of software and device files, in .tar format

* Download individual executable files for customized download and installation
The method you choose depends on your download speed, design requirements, and method
of installation. If you want the complete software package and device support for all
supported families, use the .tar format. If you want to download select elements of the
software, additional software, or additional device support, use the individual executable
files.
Related Links

Download CenterRelated Links

* Download Center: https://www.altera.com/downloads/download-centerhtml
Select Quartus Prime 16.1 Lite and download it, The following options must be selected in
order to use the STEP-MAX10.
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M select All
[¥]Quartus Prime Lite Edition (Free)
[¥]Quartus Prime (includes Nios Il EDS)

F/: 1.7 GB MD5: EEBAOE3703C46C806FE7AG61E5868DEQE
[*IModelSim-Intel FPGA Edition (includes Starter Edition)
F/: 1.1 GB MD5: 81EAE2F2D55ABECDAF1265FCDFE74760
Wl Devices

Bl E D — B R IFESE AR AQuartus Prime¥iff .

[CJArria Il device support

#: 499.6 MB MD5: 77E151BBF3876F6110AB94F7C6AG8047
[Jcyclone IV device support

P : 466.7 MB MD5: 70A27B31D439D6271650C832A9785F2C
[Jcyclone V device support

# 7 : 1.1 GB MD5: 8386E6891D17DC1FAF29067C46953FCT
[CIMAX Il, MAX V device support

#/: 11.4 MB MD5: AFCBFFO69FBAG3ES4D5DA0AES12F83A2

VIMAX 10 FPGA device support
#P: 331.3 MB MD5: 013AACB391EAD32FFBE094D9D14987C3

2.2 Installing Quartus Prime 16.1 Lite

Run QuartusLiteSetup-16.1 to begin installation. The main Quartus® Prime software

installer launches, automatically detects all other software and device support installation

files in the same directory, and installs the software and device support.
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The Welcome to the Quartus Prime Lite Setup Wizard opens, click ‘Next’

(=008 X
Setup - Quartus Prime Lite Edition (Free) 16.1.0.196

Welcome to the Quartus Prime Lite Edition [Free) 16.1.0.196 Setup Wizard.

The Quartus Prime software requires that your system have sufficient physical RaM to compile designs
targeting specific devices. You can check the "Memory Recommendations” section in the "Quartus
Prime Software and Device Support Release Notes" [https://www. altera. com/support/literature/lit-
m.html) for detailed memory requirements for a particular device.

For more information about Intel FPGA software, go to hitp:/ Awww. altera. com.

< Back [ Next > ][ Cancel ]

Click Next to open the License Agreement dialog box. Read the license agreement. If you
agree, click Yes, Next;

(3 Installing Quartus Prim

License Agreement ( lntel)

You can view the full license agreement at the link below or use ~install_lic option from command-line to get the license agreement files
before the installation. You must accept the terms of the agreement before continuing with the installation.

http: //dl. altera.com/eula

QUARTUS(R) PRIME LICENSE AGREEMENT VERSION 16.1 (WEB DOWNLOAD) -

Copyright (C) 2016 Altera(R) Corporation. Altera, Quartus, Nios(R) Il
and the Altera logos are trademarks of Intel Corporation or its
subsidiaries in the US and other countries. Any other trademarks and
trade names referenced here are the property of their respective
owners.

Certain files, programs, or other materials provided in connection -
< | u | »

I accept the agreement

() | do not accept the agreement

Do you accept this license?

InstallBuilder

< Back ][ Next > ][ Cancel
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Add additional device support to an existing Quartus Prime software installation, click Next.

 Installing Quartus Prime

Select Components

‘Q‘S"

Select the components you want to install

(=8 Quartus Prime Lite Edition (Free)

i . Quartus Prime {includes Nios || EDS) [7110MB)
=] Devices

I MaX 10 FPGA (341.9MB)

‘v [ ModelSim - Intel FPGA4 Edition (3971.5MB)

- ModelSim - Intel FPGA Starter Edition [Free) (3971.5MB)

InstallBuilder

‘You can add additional device support to an existing
Quartus Prime software installation without having to
reinstall the entire software package. Use the Install
Devices command on the Tools menu in the Quartus Prime
software to get started.

Select a component for more information

[ < Back ][ Next > ][ Cancel ]

The software will be installed.

stalling Quartus Prime Lite Ec
Installing |nte|)
Wait while Setup installs Quartus Prime Lite Edition (Free] 16.1.0.196
Installing
Unpacking files
- —
InstallBuilder
<Back || Nes> | [ _ Cancel

Select ‘Launch USB Blaster II driver installation’ to launch USB Blaster II driver installation
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and ‘Create shortcuts on Desktop’, then click finish.
\d Installing Quartus Prime Lit

Quartus Prime Lite Edition (Free) 16.1.0.196 Installation Complete

Setup has finished installing Quartus Prime Lite Edition (Free) 16.1.0.196.
I Launch USB Blaster Il driver installalinnl

Create shortcuts on Desktop

[7] Launch Quartus Prime Lite Edition

[ Provide your feedback

< Back [ Cancel

If the driver installation fails, you must install the appropriate programming cable drivers
before you can use a download cable or programming unit to program devices with the
Quartus Prime Software. The programming cable drivers are located in the following
directories:

* Windows: <drive> :\<edition>\ <version number>\quartus\drivers

Cable and Adapter Drivers Information:

https://www.altera.com/support/support-resources/download/drivers/dri-index.html

Select ‘Run the Quartus Prime software’, click ‘OK’ to launch the software.

\ =
i Quartus Prime 16.1 Lite

ditio;

Thank you for installing the Quartus Prime software - the #1 in performance and productivity. To
upgrade to a full featured edition, please visit www.altera.com.

Select one of the following licensing options to continue:

Select one of the following options

() Buy a Quartus Prime software license

@ Run the Quartus Prime software

() Add an IP license file (for users who have purchased IP)
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3.Quick Start

3.1 Create a new project

To quickly create a project and specify basic settings, click File > New Project Wizard.

O Quartus Prime Lite Edition - a E3
e ot g e s i o e
by PPN - .
D& ‘
= = PEEOLOE 9
— . ey <|QHS x| W rome o P Catalog a8
A Hew Project izard. ] Device Family Cyclona v (EIGX/GT/SX/SE/ST)
2 0 x| =
San v o nstalled P

~ progctDivectory

~ Library

Create [ Update 3
Expor,

Comvert Brogramming Files.

M pagesewp.
& proeresew

& et Ctler
Recant Fjles

Recent Frojects 3

Exit AltsF4

m [0 &R A [F o Wi | |88 rind et

e«

Type  ID  Message

Specify project directory, name, and top-level entily.

€4 MNew Project Wizard >

Directory, Name, Top-Level Entity

What is the working directory for this project?

IF:ﬂ_ED_shining I |
What is the name of this project?

| LED_shining | =
What is the name of the topJevel design entity for this project? This name is case sensitive and must exactly match the entity name in the design
file.

|LED_shining 1 =

Use Existing Project Settings. ..

= Back Finish Cancel Help
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Specify project design files, in this example, select empty project.

€4 New Project Wizard

Project Type

Select the type of project to create.

Ern|:|t5-I project

Create new project by specifying project files and libraries, target device family and device, and EDA tool settings.
() Project template

Create a project from an existing design template. You can choose from design templates installed with the Quartus II software, or
download design templates from the Design Store,

< Back Finish Cancel Help

Specify Altera device family for the design.

Family: MAX10(DA/DF/DC/SA/SF/SC) Devices: MAX 10 SC
Package: MBGA Pin Count: 153 Core Speed grade: 7
Device Name: 10M02SCM15317G

&4 New Project Wizard

Family & Device Settings

Select the family and device you want to target for compilation.
You can install additional device support with the Install Devices command on the Tools menu.

To determine the version of the Quartus II software in which your target device is supported, refer to the Device Support List webpage.

Device family Show in 'Available devices' list
Family: 'MAX 10 (DA/DF/DC/SA/SFfSC) / - Package: MBEGA -
Devices: |MAX 10 5C \ = Pin count: 153 —-— i
Tt Core Speed grade: |7 f— hd
Auto device selected by the Fitter Mame filter:
(@) Spedific device selected in "Available devices' list Show advanced devices
Other: nfa
Available devices:
Name Core Voltage LEs Total If0s GPIOs Memeory Bits
110592
10MO45CM153I7G 3.3V 4032 112 112 193536 40
10M0OBSCM153I7G 3.3V 8064 112 112 387072 43
£ >
< Back Finish Cancel Help
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Specify EDA tools to be used for this project.

b Quartus Prime Lite Edition - 0o x
i yiew Proect mssignments Processing Tools Window  Help )
crten ; > = -
= S OCOTrFrOCLOE9
Crisea Hearchy  ToNex B Home o P Catalog, Qe
] ~ Bece Famity Cyclone ¥ (E/GXIGT/SX/SE/ST)
- x| =
\ v 3 e P
* ProjectDirectory
o ¥ Ubrary
— Basic Functans
Crtsshifes -
Iterface Protocols
5 Memcey intertsces snd Cortrolers
Processars and Perpherals
o ing Files. University Program
S PRI @ Search or Patnes 1P
[ Pagesewp. Compilation
& Pint Preges
& et [
fecant £ »
Recent Projects .
Ext AteEa
L L v oAk
o OEE N F b | 88 Find e
2 [Twe T wessage
L N rd =
Summary
When you dick Finish, the project will be created with the following settings:
Project directory: F:\LED_shining
Project name: LED_shining
Top-evel design entity: LED_shining
MNumber of files added: o
MNumber of user libraries added: o
Device assignments:
Design template: nfa
Family name: MAX 10 (DA/DF/DC/SA/SF/SC)
Device: 10MO2SCM 153176
EDA tools:
Design entry/synthesis: <Mone> {<Mone =)
Simulation: ModelSim {Verilog HDL)
Timing analysis: 0
Operating conditions:
Core voltage: 3.3v
Junction temperature range: -40-100 =C
< Back Mext = Cancel Help
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The new project has been created.

| O Quartus Prime Lite Edition - Ci/1/1/LED_shining - LED_shining
1 File Edit View Project Assignments Processing Tools Window Help
IO D C e |/ GCOT>+ 2 QOLOE 9
Project Navigator o\ Hiearchy vagex P -  Catlog LR
T ACCELERATING ALGORITHMS .~ ™ [« x5
P — - Y g |
1 e
S i
o
itk
R i
Processors and Penpherals
s oy
- @ search forPartner 1P
Quartus Prime
rasks Compitation ~m s
Task Time 2
v P Compie Design
P Analysis & Synthesis
P Fitter (Place & Route)
» Assembler (Generate programming files)
P TimeQuest Timing Analysis
P EDA Nethist Writer
W cait settings % Tl
;in O &N A [v<ue | Brind | B8 FindNex
B o e
| "@ 253020 Default device 10v08DAF484C8G is automatically selected for the device family MAX 10
L
i
i 00:00:00
3.2 Add a Verilog HDL File
Select File—~New or Click the ‘New’ button, select Verilog HDL File, click OK.
& Quartus Il 64-Bit - F/LED shining/LED _shining - LED shining [m] #

File Edit “iew Project Assignments Processing Tool & New

5@ & 2@ 9 ] LED shinng

MNew Quartus II Project

altera.co

Errr—.

P OO e @B A e

Project Navigator o@x| “ Design Files IP Catalog 18 x|
@ AHDL File E —
) X Black Diagram/Schematic File ‘ Q X ‘ =5
EDIF File
Enti v ~
ty Gsys System Fle &2 Installed TP
/iy MAX 10: 10MOZSCM15317G State Machine File v Project Directory
% LED_shining & SystemVerilog HDL File Mo Selection Available
~ Library
Ay Hierarchy E| Files i Designunits  “%, 4 p WHDL File » Basic Functions
“ Memory Files > Bitec
Tasks e x| Hexadecimal {Intel-Format) Fie
> Dsp
- - Memory Initislization File
Flow: |Compllahon hd | | Customize... | v \Verification [Debugging Files > Interface Protocols
A In-System Sources and Probes File » Memory Interfaces and Controllers
Task Lagic Analyzer Interface File
) ) SignalTan T Logic Analyzer Fie » Processors and Peripherals
v ¢ Compile Design ignallap L Logi ¥ . v
— . o hd University Program VWF
< > ~ Other Files & Add
AHDL Indude File
X .
; Block Symbol File
g = @ P <cFiter>> Chain Description File
Synopsys Design Constraints File
Type iDp Message Text File
\@ 253020 Default device 10MOSDAF48 Ehe device family MAX 10
. | ok || concel || heb
&
g
=[\_system (1] Processi
0% 00:00:00

Write Verilog HDL in this file, press Crtl+s to save your files. The IDE will save the file to the

file list. Enter the code shown below.
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€} Quartus |1 64-Bit - F/LED_shining/LED_shining - LED_shining - O X
File Edit View Project Assignments Processing Tools Window Help S @
DS @ 4 0@ 9 o [Eshm Y s S¢S R T PR OO ER PP L e D
Project Navigator Aax] 4 LED_shining.v %] 1P Catalog 18 x|
Q, ;o= = =
3 X @ asd==0fTam 08 2> x| =
[ Fies ; E|n(’.od'.lle LED shining Al v 2 staled N
b i - "
LED_shi £
24 LED shining.v 3 input clk_in, //clk_in = l2mhz ' Project Directory
4 input rst_n_in, //rst_n_in, active 1 Mo Selection Available
5 output ledl, //ledl output v Library
= B [ output led2 //led2 output : 5
My Hierarchy  [E| Files " Design Units S L > P 2 34 Basic Functions
= ’ Bitec
Tasks ra x|
] parameter CLK_DIV_PERIOD = 12_000_000 DSP
Flow: |Compilation ¥ |  Customize... || 10 Interface Protocols
| == reg clk div=0; Memory Interfaces and Controllers
Task 1z 4 heral
N — Processors and Peripherals
~ = Compile Design 13 /fwire ledl,led2; "
- - . R vil14 assign ledl = clk div; hd
< > < > == Add...
x
ala |0 AllA e |© < <Filter»» @4 Find... | |#3 Find Next
!
Type ID Message £
\i) 21057 Implemented 54 device resources after synthesis - the final resource count might be different
8 \I) Quartus II €4-Bit Analysis & Synthesis was successful. 0 errors, 0 warnings "
2|« >
i
=|\_System (1] Processing (10]
100% 00:00:36

Verilog HDL code:

module LED_shining

(

inputclk_in, //clk_in=12mhz
inputrst_n_in, //rst_n_in, active low
outputledl, //ledl output
outputled2 //led2 output

);

parameter CLK_DIV_PERIOD =12 000_000;

reg clk_div=0;

//wire led1,led2;
assign led1 = clk_div;
assign led2 = ~clk_div;

//clk_div = clk_in/CLK_DIV_PERIOD
reg[24:0] cnt=0;
always@(posedge clk_in or negedge rst_n_in) begin
if(!rst_n_in) begin
cnt<=0;
clk_div<=0;
end else begin
if(cnt==(CLK_DIV_PERIOD-1)) cnt <= 0;
elsecnt<=cnt+ 1'b1;
if(cnt<(CLK_DIV_PERIOD>>1)) clk_div <= 0;
else clk_div<=1'b1;
end
end

endmodule
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Select Processing— Start—Start Analysis

& Synthesis or click Start Analysis & Synthesis

button.
€4 Quartus 11 64-Bit - F:fLEDishining/LE%hining - LED _shining - O x
File Edit View Project Assignments = Processing Tools  Window  Help S @
DEHd % 2@ 9 o W Stop Processing Ctrl+5Shift+C 8 ‘3 "'-\.E %4: \9 % Al
Project Navigator B Start Compiiation Cirl+ 1P Catalog 1ax|
Q ¥4 Analyze Current File |B‘ RS |J\h X =
| Files —»  Stat » P2 StartHierarchy Elaboration ~
¥4 LED_shining.v Update Memory Initialization File %7  Start Analysis & Elaboration
4g»  Compilation Report CUMR ¥ Start Analysis & Synthesis cirl+
4 Dynamic Synthesis Report HE,  Start Partition Merge
/Ay Hierarchy | [E]Files  of Desanui )
Ij 5} PowerPlay Power Analyzer Tool ﬁ Elathtay
Tass T 55N Analyzer Toal B Start Assembler
Flow: | Compilation o & Start TimeQuest Timing Analyzer Ctrl+Shift+T
Receive Compilation Status Notifications ﬁ- Start EDA Netlist Writer
Task = - d Controllers
as! 12 £ Start Design Assistant |
~ i 2 7 erals
P Compile Design 43 /‘/W‘}IE lEdl'iEd‘ . - '%? Start PowerPlay Power Analyzer Ctrl+Shift+P v
= ina w 14 assign ledl = clk div
-r B LI L Start 55N Analyzer
< > < &
x K Start Rapid Recompile
a a3 A (A b | <<Filters &4 Fin
1 %7 Start SignalProbe Compilation Ctrl+5hift+1
Type ID Message EE Start I/O Assignment Analysis ~
- \I) 11104 Parallel Compllation has detected 4 hyper-threaded pr @ Start Check & Save All Netlist Changes ded processors will
il v
&
alLe Start VQM Writer Ed
=|\_System (1] i
SEm Processing (4 Start Equation Writer {Post-synthesis)
Analyzes and synthesizes all of the files in the hierarchy of the current top-evel entity s . 4% 00:00:32

Quartus Prime will Analysis and Synthesis the files, if there is no error in the project,

Analysis & Synthesis in the Synthesis Tasks column turns green and a green checkmark

appears on the left. You can select Tools — Netlist Viewers — RTL Viewer to view the

circuit.

€} Quartus |l 64-Bit - F/LED shining/LED_shining - LED _shining - O x
File Edit View Project Assignments Pru:ej\‘r&Tools Window Help 5 @
- " [ =
OES @ % 52@ 9 o |[Epshnn  RunSmuiaton Too o D rdn G0 B @9 A @@
» . N - =
Project Navigator na Launch Simulation Library Compiler Loort - LED, shining [ 1P Catalog ngx ‘
Launch Design Space Explorer I
2 - TR EE x| =
A =
| Files \3 TimeQuest Timing Analyzer al o ‘% Installed P s
EE LED_shining. v e b oin = 12mhz ~ Project Directory
n in, active 1 Mo Selection Available
&  Chip Planner urput v Library
Ayvierarchy  E|Fies | of Desnunts | *3 4 48 Design Partiion Planner FrEEuE Basic Functions
= Netlist Viewers —_— Viewer
Tacks 5 & RL
o
Flow: | Compilation ~ | [ customize B SignaiTap 11 Logic Analyzer o R (R Protocal
o - rotocols
@  In-System Memory Content Editor S Technology Map Viewer (Post-Fitting) e facme and Control
Task rfaces and Controllers
=] Logic Analyzer Interface Editor @ state Machine Viewer d heral
~ B Compile Design Iﬁ e . and Peripherals
n-System Sources and Probes Editor i v
L P Analysis & Synthesis k— P w University Program
SignalProbe Pins... P
< > > o Add...
% Programmer
x
2l a8 |4 A b | T <<Fiters> P ITAG Chain Debugger 44 Find Next
ka % Fault Injection Debugger
T ID M -~
ves =ssag= System Debugging Tools »
. \I) Quartus II 64-Bit Anal 0 errors, 0 warnings
= IP Catalog ¥
gl Fw id Tools for Ec 2
o Mios IT Software Build Toals for Eclipse
=|\_System (1] Processing (10] e
Opens the RTL Viewer S O5¥S 100%  00:00:37

RTL circuit is as follows
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Equald

cnte~[24..0] LessThan0

led1
led2~not

25'h5b3da0 E[24..0]
led2

ck_in [ ant[24..0]

rst_n_in[_»

3.3 Pins Options

Select Assignments— Device to open the device configuration page, and then click the Device
and Pin Options ... to open the device and pin options page.

&4 Device x

Select the family and device you want to target for compilation.
You can install additional device support with the Install Devices command on the Tools menu.

To determine the version of the Quartus II software in which your target device is supported, refer to the Device Support List webpage.

Device family Show in ‘Available devices' list
Family: |MAaX 10 (DA/DF/DC/SA/SFE/SC) - Package: MBGA -
Devices: | MAX 10 5C - Pin count: 153 -
Core Speed grade: |7 -

Target device

Mame filter: |

Auto device selected by the Fitter

w -
(@) specdific device selected in ‘Available devices' list S TR T

Giize W i | Device and Pin Options...

Available devices:

Name Core Voltage LEs Total 1/0s GPIOs Memory Bits Embedded multiplier 9-bit el
10MO2SCM153I7G 3.3V 2304 112 112 110552 32
10MO4SCM 153176 3.3V 4032 112 112 193536 40
10MO85CM153I7G 3.3V 5064 112 112 387072 43
< >

Migration Devices... 0 migration devices selected

Concel | [

In the Unused Pins option to configure Reserve all unused pins to the As input tri-stated
state.

&) Device and Pin Options - LED shining X

Category:

Configuration
Programming Files Spedify device-wide options for reserving all unused pins on the device. To reserve individual
= nused Pins dual-purpose configuration pins, go to the Dual-Purpose Pins tab. To reserve other pins
individually, use the Assignment Editor.

Dual-Purpose Pins
Capacitive Loading
Board Trace Model
10 Timing

Voltage

Pin Placement

Error Detection CRC
CvP Settinas

== Reserve all unused pins: | As input tri-stated -
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In the Voltage option to configure the Default I / O standard for the 3.3-V LVTTL state. Then
click OK back to the design interface.

&4 Device and Pin Options - LED shining

Category:
Configuration
Programming Files Specify voltage options for the device.
Unused Pins
Dual-Purpose Pins =i Default I/0 standard: |3.3—'\.|' LVTTL -
Capacitive Loading WCCIO 1O bank1 volt in MAX 10 Pin Pl to adjust VCCIQ volta
! f W = - -
Bioard Trace Madl a /O bank1 voltage: |nfain use Pin Planner to adjus voltage
1jC Timing " . . ) T ) .
VCCIO If0 bank?2 voltage: | mfain MAX 10 — use Pin Planner to adjust WCCIO veoltage =
Voltage
Pin Placement Core voltage: 1.2V
Select Assignments — Pin planner option or toolbar Pin planner button, enter the pin
distribution interface.
&4 Quartus 1l 64-Bit - F/LED shining/LED_shining - LED_shining - O X
File Edit View Project  Assignments Processing Tools  Window Help S @
DEd@ ¥ o Wy ref@le o ron O M2 @9 A @@
Project Navigator = Settngs... EHHEIRE g Compilation Repart - LED_shining [ 1P Catalog rax
Q & Assignment Editor culshiftea 5 o mOm 05 @ [a x| =
5 Files == PinPlanner CUl+Shift+Hl  LeD shining Al v 2 installed P "
LED_shining.v S k_in, //clk in = 12mhz " Project Directory
i% Back-Annotate Assignments... t n in, //rst n in, active 1 Mo Selection Available
Import Assignments... edl, //ledl output ~ Library
Ay Hierarchy ) Files Export Assignments. . ed2 //ledZ output Basic Functions
Tasks Assignment Groups... Bitec
i r CLK DIV PERIOD = 12 000 000 DSP
Flow: |Compilation %)  LogicLock Regions Window Alt+L Interface Protocols
£ Design Partitions Window Alt4D |div=0; Memory Interfaces and Controllers
~ B Compile Design 13 S/wire ledl,ledZz; Frocessors and Peripherals
o P Analysis & Synthesis © 14 assign ledl = clk_div; v University Program w
< > 2' A oo > i Add...
; Al D A A 4 |? < <Filter > @4 Find... | | Find Next
I
|Ty'pe ID Message "|

In the Pin Planner page, all ports assigned to the corresponding FPGA pin, as shown below,

then close (automatically saved).
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55 Pin Planner - F/LED _shining/LED shining - LED shining

O bd

File Edit View Processing Tools Window Help 5 Search altera.com 6
@ EP"”: iax | Top View - Wire Bond
Report not available MAX 10 - 10M025CM15317G
L
)
O
"
Ji Groups Report
D | asks ogx| e
™ ~ [Z Early Pin Planning ~
] Early Pin Planning. .. e
¥ Run Ij0 Assignment Analysis
3 Export Pin Assignments...
[ Pin Finder... v
x Named:| = ~ ||<<>>| Edit: | 3% J|PIN_39 |Fi\ber:|Pins: al -
=]
1 Mode Mame Direction Location Ij0 Bank VREF Group 10 Standard Reserved Current Strength Slew Rate
PIN 39 s BN 33VW.defalt)  GmA(defadt)
<<new node >
£
T
=« >
0% 00:00:00

Select Processing— Start Compilation option, waiting for the Tasks list of all options to

complete, as shown below.

> [ Analysis & Synthesis Total logic elements 51/2,304(2%)
5 [ Fittes Total combinational functions 51/2,304(2%)
al Dedicated logic registers 26/2,304(1%)
> [0 Assembler Total registers 25
= DG > i
My Herarchy | [Z]Fies  of DesignUnits %, 4 }| (3 PowerPlay Power Anclyzer EEE S
> [ TimeQuest Timing Analyzer Total virtual ping a
Tasks 18 x ‘ > (21 EDA Metlist Writer Total memory bits 0/110,592 (0 %)
: i Embedded Multiplier 9-bit elements  0/32(0%)
€ It 1} Flow Messages
Flow | ompilation v| ‘mstomwze | 3 ) g , Total PLLs 0/1(0%)
ok ~ Flow Suppressed Messages \UFM blacks 0/1(0%)
ADC blocks ]
Y 4 ~ I Compile Design
L' 4 » P Analysis & Synthesis
L > B Fitter (Place &Route)
L d » B pssembler (Generate programming files)
' > B TimeQuest Timing Analysis
L > W EDA Netlist Writer
Hlie Pronram Nevics (Nnen Praarammer) A
< > < >
x 7310
al e (@ A |2 <<Fiters> [ @ end.. | |32 Findnext|
1
| Type ID Mes=zage

3.4 FPGA Programmer

Connect the the STEP-MAX10 to PC by micro-usb cable. Select Tools—Programmer or click

Programmer button.
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J Quartus |l 64-Bit - F:/LED_shining/LED _shining - LED shinin
' g . 9 _: =]

Window  Help =2
Run Simulation Tool
Launch Simulation Library Compiler

Launch Design Space Explorer I
TimeQuest Timing Analyzer
Advisors

Chip Planner
Design Partition Planner

Netlist Viewers

SignafTap I Logic Analyzer
In-System Memory Content Editor
Logic Analyzer Interface Editor
In-System Sources and Probes Editor

SignalProbe Fins...

Opens a Programmer window

Eile Edit Vew Project Assignments Processing Tools
DA @ % 2@ 9 o EpShinin
>
Project Navigator Rg
Q, &
[ Files i
LED_shining. v
@}Hlerard’w Fg“ Files & Design Units "\ 4 %
Tasks q1a
Flow: | Compilation hd Cusmmm@]
-
Task
E
¥ 4 v I Compile Design @
- e 5
x o _D
alla| @ AR [ [T pr——
n &
Type ID Message %
P Quartus II 64-Bit EDA
o \') 293000 Quartus IT Full Compil _
&
al| <
i
=|\_System (1) /\_Processing (136) /
A

JTAG Chain Debugger
Fault Injection Debugger
System Debugging Tools

IP Catalog
Nios IT Software Build Tools for Edlipse
Osys

- O X
[Searchalleracom | @
" o S
o O e U e 90]a o @
1P Catalog nax|
Y I ERE) x| =
A v 2B Installed P -
n = 12mhz “ Project Directory
_n_in, active 1 Mo Selection Available
ucput ~ Library
proput > Basic Functions
> Bitec
0D = 12 000 000 > DSP
» Interface Protocols
> Memory Interfaces and Controllers
> Processors and Peripherals v
v
> o Add...
ﬁ Find Next
A
errors, 1 warning
17 warnings
v
>
100% 00:01:21

Programming interface as below, confirm the hardware driver is USB-Blaster[USB-0], select

‘Add File’ to add the project output file(.pof), select Program and Verify column, click the

start button to programming for FPGA.

Uk Programmer - F/LED shining/LED shining - LED shining - [Chain2.cdfl*

O

X

File Edit WView Processing Tools Window Help = @
_3. Hardware Setup. .. IUSB—BIasher [UsB-0] I Mode: | JTAG hd Progress: [ ]
[] Enable real-time ISP to allow background programming when available
T File Device Checksum Ugercode Program, Verify Blank- Examine
Configure Chedk
s output_files/LED_shining.... 10M025SCM153 00656A95 00000000 O
CFMD ]
&l Auto Detect UFM U
& Delete
I (4 Add File... I g >
A
'i“_,‘ Change File...
| save File
E} Add Device...
Hiup
JHiDown 10MO25CM153
TDO
4
v

3. FPGA programming is complete, the progress shows 100%(successful). Observe the

development board.
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Uk Programmer - F/LED shining/LED shining - LED shining - [Chain2.cdfl* — O ®
File Edit WView Processing Tools Window Help = @
3. Hardware Setup... |USB—BIasher [usB-0] | Mode: | ITAG hd Progress: [ 100% {Successful) J

[] Enable real-time ISP to allow background programming when available

W File Device Checksum Usgercode Program, Verify Blank- Examine
bt Start Configure Check
T output_files/LED _shining.... 10MO2SCM153 00656435 00000000 O
2 CFMO [
&l Auto Detect UFM (]
Delete
(4 Add File... g 2

2 Change File...
‘Al Save File
(% Add Device...

T up

[t Down 10MOZ5CM153

4.Modelsim-Intel quick start

The Quartus Prime software supports loose or tight integration with many industry standard
EDA tools that may be used in a complete FPGA design flow. You can use the Mentor Graphics
ModelSim-Intel FPGA Edition software, provided with the Quartus Prime software, to
perform a functional simulation of a VHDL or Verilog HDL design that contains Intel-specific
components with the ModelSim-Intel FPGA Edition interface, or with command-line
commands.

1. First of all to prepare the testbench file: LED_shining_tb.v

“timescale 1Ins / 100ps
module LED shining tb;

parameter CLK PERIOD = 40;

reg sys clk;

initial
sys_clk = 1'b0;
always
sys_clk = #(CLK PERIOD/2) ~sys clk;

reg sys_rst _n; //active low

initial
begin
sys rst n = 1'b0;
$200;
sys rst n = 1'bl;
end
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wire ledl,led2;

LED shining #

(

.CLK_DIV_PERIOD(4'd12)

)

LED shining uut

(

.clk in(sys _clk), //clk in = 12mhz
.rst n in(sys rst n), //rst n in, active low
.ledl(ledl), //ledl output
.led2(1led2) //led2 output

)r

endmodule

2. Choose the menu Assignments - > Settings or Settings button in the toolbar, set into the

interface.
&4 Quartus Il 64-Bit - F/LED_shining/LED_shining - LED_shining - m} x
File Edit View Project | Assignments | Processing Tools Window Help ==Q @
& ™ 8 s _._. =
D@ £ ove M9 O rpon 0 W @9 A 0D
*  Settings... Crl+5hift+&
Project Navigator —= t - LED_shining [£J IP Catalog oax|
Q, \J Assignment Editor Ctrl+shift+A Y- m Q b 4 | =
o] " | il S
[ Files W b Tk ETE Flow Status A | ¥ 22 Installed P ~
EE LED_shining. v Remave Assignments... Quartus IT “ Project Directory
i‘} Back-Annotate Assignments... jut Global Settings Revon N Mo Selection Available
Import Assignments... e =k + Library
e | Bry Family
% Hierarchy [El Files Export Assignments... Device Basic Functions
Taske Assignment Groups... b Timing Mod Bitec
o5 Total logic ¢ DsP
. = o . )
Flow: |Compilation 54 Logiclock Regions Window Alt+ Total o Interface Protocols
i Design Partitions Window Alt+D Dedica Memory Interfaces and Controllers
=T FOWErFTEy Fomer Analyzer Totalregist Processors and Peripherals
~ i = v
V,. L C-om|-:nle .DESIQ-H_ — w (3 TimeQuest Timing Analyzer ") Iof! D‘”f ™
< > < > < > 2 Add...
x L7 10 =
s la 8 |4 A e |§9 <<Filter> > @3 Find.. | &3 Find Next
J;
Type i Meszzage ~
i 10905 Generated the EDA functional simulation files although ED& timing simulation option is chosen.
8 i) 204019 Generated file LED shining.vo in folder "F:/LED shining/simulation/modelsim/" for EDA simulation tool W
e - —
IS >
]
=|\_System (4 Processing {136
Change the Settings 100% 00:01:09

3. Choose the menu Setting, select Simulation options, then Compile test bench. Now you can
click Test Benches to create a new testbench file. (Or you can add the prepared testbench file to
your project directly).
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N
— [m] x & Test x

Specify settings for each test bench.

Category: Device... P
Files
Libraries Specify options for generating output fles for use with other EDA tools, hame Top Level Module  Design Instance Edit...
v IP Settings
IP Catalog Search Locations Tool name: | ModelSim - Delete
Design Templates
 Operating Settings and Conditions [ Run gate-fevel simulation automatically after compilation
Voltage A < 3
Temperature EDA Netist Writer settings
v Compilation Process Settngs Format for output netlist: |Verilog HOL - Time scale: | 1ps - OK Cancel Help
Incremental Campilation
~ EDA Tool Settings Output directory: i . N X
fcunthesis ‘ " New Test Bench Settings X
1 [ Map ilegal HDL characters [ Enable glitch filtering
Formal Verification Options for Power Estimation Create new test bench settings.
Board-Level
v Compller Settings [ Generate Value Change Dump (VCD) file script | Seript Setbngs. . Test bench name: | LED_shining_tb | 3 ]
VHDL Input
Veriog HDL Tnput Design instance name: Top level madule in test bench: |LED_shining_t | |
Default Parameters [] Use test bench to perform VHDL timing simulation
TimeQuest Timing Analyzer
Assembler More EDA Netlist Writer Settings... Design instance name in test bench: NA
Design Assistant N
Simulati od
SionalTap T Logic Analyzer NativeLink settings imudation perio
Logic Analyzer Interface ) Nane (@ Run simulation until all vector stimuli are used
PowerPlay Power Analyzer Settings
SSN Analyzer 2 nmpde test bench: - (O End simulation at: s T
[ use script to set up simulation: Test bench and smuation fles 7
(O script to complle test bench:
More NativeLink Settings... Reset
LED_shining_tb.v
Up
Down
Praperties...
oK Cancel Apply Hep
oK Cancel Help

4. Choose the menu Tools -> Run Simulation Tool -> RTL Simulation or RTL Simulation button in
the toolbar, start Modelsim-Intel software.

&4 Quartus 11 64-Bit - F:/LED_shining/LED_shining - LED_shining - O x
File Edit View Project Assignments Prooe% Tools  Window Help :=‘j
DEHE| ¥ G2E[9 o [ isensmiaten ool 32 RTL Simulation =
Proiect Navidator ng #.  Launch Simulation Library Compiler "?x Gate Level Simulation. .. 018 x|
Q, ‘g Launch Design Space Explorer I ‘ 3 x | E,
[ Files 'G} TimeQuest Timing Analyzer - ‘% Installed P o
LED_shining.v Advisors y  |QuartusII “ Project Directory
HERS No Selection Available
@ Chip Planner Top-evel E v Library
o . . Family
/% Hierarchy Files P Design Units w4 % Design Partition Planner Device *» Basic Functions
@ ig Metlist Viewers * |Timing Mod S Bitec
. § i Total logic ¢ > DSP
Flow: | Compilation ~ | | Customize SignalTap Il Logic Analyzer Totalo > Interface Protocols
& In-System Memory Content Editor i
¥ ¥ Dedica > Memory Interfaces and Controllers
=]  Logic Analyzer Interface Editor Total regist
v Total pins > Processors and Peripherals v
- @ In-System Sources and Probes Editor e D‘ .
o kY & Add...
g v SignalProbe Pins. .. i v il
x 9 o Programmer
s a8 |5 A |La |T c<Fiters> W Prog 4 Find Next
ﬁ] ITAG Chain Debugger
Type ID Meszzage % Fault Injection Debugger ]
i 10905 Generated the EDAE func System Debugging Tools » P EDZ timing simuwlation option is chosen.
n
o i) 204019 Generated file LED shi Rg/simulation/modelsim/"™ for EDA simulation tool W
e -
gl < @l P Catalog >
]
=|\_System (4 Processing (136 Nios 11 Software Build Tools for Edipse
Rung the specified RTL simulation tool A asys 100%: 00:01:09

5. Modelsim-Intel software start automatically after complete code compilation, as below.
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M ModelSim SE-64 10.1¢

File Edit WView Compl\e Simulate Add Structure Tools

Layout Bookmarks

Window

~u

=

o-mg| Heu:lim

|®

| - 4 4

ColumnLayout |Al 1Columns

JHQ'@'@'@H

[T a4 ad

e

Je & o M Do 3L

51

i vibrary ——= @s- Default —— :——1 H 41 x| |§ Objects s Hdx

'1Name '11r1513r1ce ‘_lDEslgn unit '1Narr|e |Va|ua ||Gﬂd |Mude "

(£l work =+l LED_shining_th LED _shining -~ CLK_DIV_PERIOD 1100 . Internal

:Hil altera_Insim_ver = ED g ED g

[zh4li} altera_mf_ver & #ASSIGN#15  LED_shining

(zhli} altera_ver @ #ASSIGN#14  LED_shining

(=4l fiftyfivenm_ver o & #ALWAYS#19  LED_shining

(=4l o _ver @ =INITIAL#13 LED _shining

ﬂ-m sgate_ver & #FINITIALET LED_shining| [ +

(x4 ri_wark @ FALWAYSEY LED_shining

[+l floatfixiib |’ #vsim_capacitys |# Processes (Active) H A

(=l machxo2 MName Type (filtered) AE |

il me? b femnt) d 4 ZASSIENZ 14 Assion JB

3| Hl B vl | vl | |

Q Tansoipt ————————————————————

4 run -all

Now: 3,661,642,920 ns Delta: 0 [sim: \LED_shining_tb/LED_shining_uut | [ fkeen| o] y
6. Right click Add Wave in the pop-up menu to add the selected signal that you want to oberve
to the signal Wave window.

M Library —— @ sim - Default — HA % *(lg!:ls s H A x|
"IName ﬂlnsmnce \_|Design unit "IName |'\¢'alue ||Gr1d |Mode
(el work ! LED_shining_th LED_shining « CLK_DIV_PERIOD 1100 Para... Internal
[+l attera_nsim_ver = LED_shining_uut  LED_shining 4 dkin St Net  In
[zl attera_mf_ver & #ASSIGN#15  LED_shining 4 rst_n_in St Met In
(gl altera_ver & #ASSIGN#14  LED_shining ® e View Dedaration ¢
[+l fiftyfivenm_ver o & FALWAYS#19  LED_shining L Viemory Contents t
(x4l tom_ver & =INITIAL#13 LED_shining » d

[+l soate_ver & =INITIALE7 LED_shining| |[ =~ | Add Wave Cirl+w

[+l rtl_work o & FALWAYSHS LED_shining & x Add Wave New

) ) P
(=l floatfixib [ #vsim_capacity 9% pdd WaveTo *
[#Hli, machxo2 Mame
Wl me? lih femntd d Add Dataflow Ctrl+D
ll | ] [N 3 | [ 8 [ [ add to 3

7+ You can choose the menu Tools -> Restart or Restart button in the toolbar, to reset the

simulation Wave window.
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=

File Edit View Add Format Tools Bookmarks Window Help
| Wave - Default

BH-2ldo S
34059
B Er s i | tatizas
EX T M fesen g

o o] x|

=

|aaean

List Format
Wave Format
Breakpaints
Logged Signals
Virtual Definitions

BEEEEE:

Assertions
Cover Directives
ATV Format

I\ 2507 ps to 4073 ps | 1LED_shining_tb LED_shining_uuit/CLK_DIV_PERIOD

» I

8. You can modify the simulation time in the toolbar, then click the Run button. Now you can
check the simulation wave or modify other parameters to generate the Wave as you want.

B Wave — [m] x
File Edit View Add Format Tools Bookmarks Window Help
pm| Wave - Default &
H-ed S rRBD 0N || SEAN|| o s H wosuuHe  0we
33989
R ECERs i 1T
¢ - 4L - B | Search: ﬂ&?%ﬁ%ﬁ}|
< Msgs.

#  JLED_shining_tb/LED_shining_uut/CLK_DIV_PERIOD |12

4 JLED_shining_th/LED _shining_uut/dk_in St1

4 LLED shining_th/LED_shining_uut/rst n_in st1 |
B /LED_shining_th/LED_shining_uutfcnt 5 0 s Te Y47 Js Jo YDA T 2 YEA 15 5 17 B[ Jo[u 1 s 1

JLED _shining_th/LED _shining_uutfdk_div 1]

#. LED_shining_th/L ED_shining_uutfled 1 St
#. JLED_shining_th/LED_shining_uutfled2 5t1

& ] X

s

|tatitaas

JQQQ@U’“?;

r“@me Mow |00 ps
e Cursor 1 |795 ps

[ [@

<] 3 KT [ 2
[ 0ps to 1357873 ps [ 1.ED_shining_tb/LED_shining_uut/CLK_DIV_PERIOD
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5.Version
Version number Date Comments
1.0 2017/2/14 Initial Version
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